TheAMCForum.com Homepage
Forum Home Forum Home > The Garage > Electrical - non engine
  New Posts New Posts RSS Feed - turn signal issue
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Click for TheAMCForum Rules / Click for PDF version of Forum Rules
Your donations help keep this valuable resource free and growing. Thank you.

turn signal issue

 Post Reply Post Reply
Author
Message
javman7 View Drop Down
AMC Apprentice
AMC Apprentice


Joined: Aug/17/2013
Location: roseville ca
Status: Offline
Points: 202
Post Options Post Options   Thanks (0) Thanks(0)   Quote javman7 Quote  Post ReplyReply Direct Link To This Post Topic: turn signal issue
    Posted: Apr/16/2018 at 8:43pm
This may be tough to sort out online but ill give it a shot before I call a professional. I'm having trouble getting my turn signals to work front and back. Ive got the headlights and taillights working, interior lights, cluster lights working. I have power at the fuse block, power into the flasher but I don't not have power at the plug ends where the turn signals plug in to in front of the car. I have a brand new directional switch installed, a brand new flasher and ive double checked that everything is plugged in. Ive tested the turn signal housings and they light up when power is applied.

This is for my 66 rogue. What am I missing. I'll admit I'm a electrical dummy. Thanks for any advice.
Back to Top
knightflight View Drop Down
AMC Apprentice
AMC Apprentice
Avatar

Joined: Jan/30/2014
Location: Nor. Calif.
Status: Offline
Points: 208
Post Options Post Options   Thanks (0) Thanks(0)   Quote knightflight Quote  Post ReplyReply Direct Link To This Post Posted: Apr/16/2018 at 11:45pm
Take your test light and ground the clamp to the a good ground and touch the probe end at the cold side of the flasher, not the battery side (key on). The test light should flash since this gives it a load directly. If it does, you may have a bad connection at the switch, If no flash, you have a defective flasher. I know it is new, but MANY are bad out of the box nowadays.
Go from there.
Walt
'67 Rebel SST conv.
'68 Rebel SST coupe. (X2)
'69 SC/Rambler (#6 on registry)
'69 Javelin SST Go-Pak 390-4 speed
'70 Rebel Machine 4spd
'74 Hornet-X hatchback
Back to Top
javman7 View Drop Down
AMC Apprentice
AMC Apprentice


Joined: Aug/17/2013
Location: roseville ca
Status: Offline
Points: 202
Post Options Post Options   Thanks (0) Thanks(0)   Quote javman7 Quote  Post ReplyReply Direct Link To This Post Posted: Apr/17/2018 at 10:17am
With the key on I have power at the flasher coming from fuse block, I have no power coming out of the flasher. (Blue wire) I'll replace it and see what happens.
Back to Top
javman7 View Drop Down
AMC Apprentice
AMC Apprentice


Joined: Aug/17/2013
Location: roseville ca
Status: Offline
Points: 202
Post Options Post Options   Thanks (0) Thanks(0)   Quote javman7 Quote  Post ReplyReply Direct Link To This Post Posted: Apr/17/2018 at 10:20am
Back to Top
knightflight View Drop Down
AMC Apprentice
AMC Apprentice
Avatar

Joined: Jan/30/2014
Location: Nor. Calif.
Status: Offline
Points: 208
Post Options Post Options   Thanks (0) Thanks(0)   Quote knightflight Quote  Post ReplyReply Direct Link To This Post Posted: Apr/17/2018 at 10:56am
Try it and post what happens, we'll go from there.
Walt
'67 Rebel SST conv.
'68 Rebel SST coupe. (X2)
'69 SC/Rambler (#6 on registry)
'69 Javelin SST Go-Pak 390-4 speed
'70 Rebel Machine 4spd
'74 Hornet-X hatchback
Back to Top
javman7 View Drop Down
AMC Apprentice
AMC Apprentice


Joined: Aug/17/2013
Location: roseville ca
Status: Offline
Points: 202
Post Options Post Options   Thanks (0) Thanks(0)   Quote javman7 Quote  Post ReplyReply Direct Link To This Post Posted: Apr/17/2018 at 1:35pm
I have power on both sides of the flasher now. Granted my test light is much dimmer when testing the blue wire side of the plug which is the wire going to the directional switch plug, compared to the weed side coming from the fuse block. I noticed that when I move the turn signal lever, I can hear the flasher click but it only does it once and stops. It doesn't continue. I also have no directional indicator light coming on in the gauge cluster.

Edited by javman7 - Apr/17/2018 at 1:40pm
Back to Top
javman7 View Drop Down
AMC Apprentice
AMC Apprentice


Joined: Aug/17/2013
Location: roseville ca
Status: Offline
Points: 202
Post Options Post Options   Thanks (0) Thanks(0)   Quote javman7 Quote  Post ReplyReply Direct Link To This Post Posted: Apr/17/2018 at 4:36pm
Ok I got them to work! Walt, you were right. A third flasher switch fixed the problem. Thanks
Back to Top
knightflight View Drop Down
AMC Apprentice
AMC Apprentice
Avatar

Joined: Jan/30/2014
Location: Nor. Calif.
Status: Offline
Points: 208
Post Options Post Options   Thanks (0) Thanks(0)   Quote knightflight Quote  Post ReplyReply Direct Link To This Post Posted: Apr/17/2018 at 8:05pm
Cool! Glad it works.
Walt
'67 Rebel SST conv.
'68 Rebel SST coupe. (X2)
'69 SC/Rambler (#6 on registry)
'69 Javelin SST Go-Pak 390-4 speed
'70 Rebel Machine 4spd
'74 Hornet-X hatchback
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.063 seconds.
All content of this site Copyright © 2018 TheAMCForum unless otherwise noted, all rights reserved.
PROBLEMS LOGGING IN or REGISTERING:
If you have problems logging in or registering, then please contact a Moderator or