TheAMCForum.com Homepage
Forum Home Forum Home > The Garage > Electrical - non engine
  New Posts New Posts RSS Feed - Directional Hyper Flash ???
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Click for TheAMCForum Rules / Click for PDF version of Forum Rules
Your donations help keep this valuable resource free and growing. Thank you.

Directional Hyper Flash ???

 Post Reply Post Reply
Author
Message
NJ AMX View Drop Down
AMC Fan
AMC Fan


Joined: Jul/03/2020
Location: Brick, NJ
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote NJ AMX Quote  Post ReplyReply Direct Link To This Post Topic: Directional Hyper Flash ???
    Posted: Sep/14/2020 at 10:17am
I recently purchased a 1969 AMX and "one" of the issues with the car is what appears to be that the directional lights flash super quick. My friend who is a tech at a dealer replaced both the directional and hazard flashers but neither corrected the issue. All the "exterior" bulbs blink but the left hand "dash" indicator is out, and I have not had it checked/replaced yet, but also, a previous owner installed an aftermarket clock, but I do have the ability to ask who/when it was installed as the previous owner has passed and his family has little knowledge of what he did verses the previous owner did. The previous owner purchased the car in 2004 but with no records of work done, the clock could have been installed over a decade ago. The car is currently having body work done so I will not have it back for some time to attempt other checks, but would appreciate any recommendations on what to look for.
Back to Top
Hogman View Drop Down
AMC Apprentice
AMC Apprentice


Joined: Jan/02/2018
Location: Sarnia Ontario
Status: Offline
Points: 190
Post Options Post Options   Thanks (0) Thanks(0)   Quote Hogman Quote  Post ReplyReply Direct Link To This Post Posted: Sep/14/2020 at 10:53am
Are the indicator Bulbs all incandescent, or have ANY of them been Replaced with LED's or Any other NON Stock style Bulb(s)? Look them up & then Check Yours. MAYBE Some previous owner installed 1156's, when they MAYBE should have been 57's??????? (or Vice Versa????) like I say though, Check what Your car calls for First! 
IMHO, I DOUBT it's a Bad/Poor Ground, but then again I haven't Looked up any Wiring Diagram for Your Car........
POSSIBLY Even the INCORRECT Bulbs????? I Can't say for SURE What Bulbs You NEED.

The Dash light sounds like just a Burnt out Bulb.......

Hopefully this is SOME Kind of Help....... GOOD LUCK!





ME
Hogman
Back to Top
Buzzman72 View Drop Down
AMC Addicted
AMC Addicted
Avatar

Joined: Sep/15/2009
Location: Southern IN
Status: Online
Points: 1896
Post Options Post Options   Thanks (0) Thanks(0)   Quote Buzzman72 Quote  Post ReplyReply Direct Link To This Post Posted: Sep/14/2020 at 12:00pm
Dash indicator sounds like a burned out bulb.

Fast flash indicates high current draw. It heats up the element in the flasher quickly. Flasher breaks the circuit before a fuse is blown, so the problem is between the flasher and the bulb. Might be a bad socket, might be a pinched wire. The clock installation tale has me leaning toward the pinched wire theory.

Or it could be unrelated.

Buzzman72...void where prohibited, your mileage may vary, objects in mirror may be closer than they appear, and alcohol may intensify any side effects.
Back to Top
Steve_P View Drop Down
AMC Addicted
AMC Addicted
Avatar
Charter Member

Joined: Jun/28/2007
Status: Offline
Points: 2151
Post Options Post Options   Thanks (0) Thanks(0)   Quote Steve_P Quote  Post ReplyReply Direct Link To This Post Posted: Sep/16/2020 at 9:05am
There are different flashers- make sure you have the correct one as incorrect will flash faster.
Back to Top
hassyfoto View Drop Down
AMC Addicted
AMC Addicted
Avatar

Joined: Nov/16/2009
Location: Maryland
Status: Offline
Points: 3061
Post Options Post Options   Thanks (0) Thanks(0)   Quote hassyfoto Quote  Post ReplyReply Direct Link To This Post Posted: Sep/17/2020 at 4:19am
My Comanche had the same issue. After several attempts to find the issue it was found that different bulb manufacturers was the issue. I replaced all the bulbs with the same made manufacturers. Resolved the issue. 
In the past I have found similar issues to be:
A ground issue, dirty or rusted bulb contacts ( both the bulb and the wire harness contact side)
As already stated a pinched, damaged, partially cut wire
Incorrect or mismatched bulbs. As already stated 1156 vs 1157
Improperly installed bulbs. I’ve seen bulbs forced into the socket and the side pins were backwards,, therefore the bulbs does not seat properly making for a poor contact
New bulbs that are bad. Don’t assume new is good. ( one element is damaged out of the 2 elements)

The dash bulb and clock should not effect the external light issue.

Murphy's Law:
Any given mechanical job you decide to solve alone will imminently require a third hand, at its most critical moment

Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.078 seconds.
All content of this site Copyright © 2018 TheAMCForum unless otherwise noted, all rights reserved.
PROBLEMS LOGGING IN or REGISTERING:
If you have problems logging in or registering, then please contact a Moderator or